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TimeTable Suite 
FAQ’s 

 

Exams  
 

How do I build an Exam Timetable?  
 
1. Enter TTSM and choose Timetable Assistant  

2. Choose 1 Step through…  

3. Select the Year Levels you wish – click Next  

4. Subject Set Selection: If this is the first time you are setting up your exams then 

highlight the default set; and (VERY IMPORTANT) click Duplicate the selected 

set  

 At the yellow screen in the Option Lines box choose the 2nd option Attach to a 

new BLANK set of Option Lines  

 Give your set a name eg. Exams 2008  

 Click OK - this could take a bit of time to set up so be patient  

 Choose the new set you have created - NOT THE DEFAULT SET (in red) by 

mistake  

5. Load Option Lines: Choose the top button Load ...... from Student Manager  

6. Enter the Student Editor and unpin all subjects if they are pinned at present using 

the Pin button. (If the grey line to the right of student’s subjects has an 

exclamation mark then their subjects are pinned.)  

7. Choose Utility > Delete subjects, to remove any subjects that you do not wish 

to examine.  

8. If there are subjects you wish to keep apart eg. 11ENG, 12ENG and 13ENG use 

the Teacher Editor to create a teacher called eg. MATHS code MT and give them 

these subjects. This will ensure 'the MAKER' places these in different lines. It is 

suggested you try generating lines without doing this first as it may not be 

necessary.  

9. At the Main Menu go to Make Option Lines ('the Maker')  

10. 10 Choose the numbers corresponding to years 11 and 13 (probably 5 and 7); 

press ENTER  

11. Choose Make Option Lines  

12. Consider lines 1 to 10 to coincide with your 10 half-days from Monday morning to 

Friday afternoon. In the mask each exam subject should have a dot in lines 1 to 

10 and they must have one class indicated (ie. the exam runs once).  

13. If you find you have some non-exam subjects listed (they may have been missed 

in step 7 above), in order that they don't cause problems let them have the same 

mask but let them run 10 classes in 10 lines. This will place them in every line 

and hence they will be no constraint. You can then ignore them.  

14. 13 Choose BUILD to generate your timetable (ie. exam lines) and indicate which 

pupils won't fit  

15. Use the normal tools (eg. What If?) and the Editors to tune your timetable lines  

16. EXIT TAS saving any changes  
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How do I remove all classes at particular year levels to show the timetable 
during exam time?  

 
Teacher Editor > Spreadsheet > Replace > subject 11**** with blank > All 

teachers  
This will remove year 11 classes.  
 

REMEMBER – if you wish to save this, use a new number so you don’t wipe out your 
current timetable.  

 
 
Printing  

 
How do I print all the rolls for a particular period? (This is useful for a fire drill, etc)  

 

QuickFind > Teacher Information > Rolls  

Select Teachers >  

Select the day and/or periods >  

normal rolls >  

select day  

UNCheck    Show only those periods .. > choose the period > NEXT  

choose the format options > NEXT > Print  

 
 

How do I print all the timetables for a given year level sorted by class?  
 

QuickFind > List Menu > Student Lists > Select > Year level > Print  

Pupil Timetables > Current Selection > sorted by class  

 
 
How do I print the period by period attendance for all the students in a class?  
 

QuickFind > Student Information > Select the class required  

F8 will take you straight to their attendance page. Press the yellow Period by Period 
button > Print this selection.  

 
How do I print all the form class rolls at a given year level?  
 

QuickFind > Student Information > Select the year level required eg. year 11 > 
Print > Student Timetables > the current selection > sorted by form class.  
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Timetable  
 

How do I enter shared classes?  
 

Example 1:  
 Assume there is a subject 13HIS taken for 2 periods by teacher AB and 2 periods 

by teacher CD in line F. Give all the students in their line F 13HIS-AB.  

 There is no need to mention teacher CD in the student subjects. This means only 

13HIS-AB appears in the option lines.  

 Then on teacher AB's timetable just enter F 13HIS in whatever room as normal 

but just for the 2 periods (s)he takes them. On Teacher CD's timetable enter F* 

13HIS in whatever room for the two periods (s)he takes them. The asterisk 

indicates this teacher is taking someone else's class.  

 
Example 2:  

 Assume a student has 13STY in line F and it is taken by SM, BY, TK and DL for 

the 4 periods. Give the student 13STY with ANY of the listed teacher codes in 

their line F in Student Manager. Choose the first teacher the students have (eg 

13STY SM). For teacher SM enter F 13STY followed by the room on their 

timetable as usual. For the other teachers, in the period they take this class, 

enter on their timetable F* 13STY followed by the room. The '*' (star) indicates 

they teach ANY pupil who has 13STY in line F as opposed to ONLY those pupils 

who have 13STY-SM (or 13STY-BY etc). The only subject in the option lines and 

hence on the students is 13STY-SM  

 If there are two or more studies occurring in this line, use coding such as 

13STYA and 13STYB to indicate which group the teacher is taking.  

 
 
Photos  

 
How do I show teacher photos?  

 
Create a sub folder in your TTSM folder called STAFF eg. M:\TTSM\STAFF. Place in 
there your photos using the teacher codes eg, BDE.JPG, MYL.JPG etc. You can use 

either JPG or BMP format.  
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Reports  
 

Archiving Reports  
(this process creates a unique folder for each student where their reports, etc, can be 

printed to using the PDF printing option in ClassRoom Manager) 
 
Step 1: CM Admin  

1  Other Utilities – PDF Setup 
 

 
 

In Step 1 choose the code you wish to use. It is very important that the same one is 
used each time.  
 

In step 2 type the @ symbol 
 

Step 3 click Generate 
 
The following box will pop up.  
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Click Save.  

 
You may get the following two messages pop up. If so, answer Yes to both.  

 

 
 

Click OK when finished  
Click Finish  
 

 
Archiving Reports  

 
 Open the required report document in CM Teacher. Click on Grid button (bottom 

left of report)  
 

 Click on Filter. Filter for required year level (same as report opened) (eg. Year 9 

Report document – filter for Year 9 students)  
 

 Click on person (bottom left of report) to return to the individual report  
 

 Click on Print  
 

 
 

 In the ‘Print for’ area click to place a dot next to All students in current filter  
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 In the ‘Doc printing options’ area tick the Save in PDF format instead of 
printing box; and place a tick in the Use students’ logins as subdirectories 

 

 Click on Print  

 
 Highlight the pdf folder (or the folder you wish to use) folder. Click Ok  

 

 
 
Other  

 
How do I move data from the server to a laptop and back again?  

 
This is something that timetablers sometimes need to do if they don’t have remote 

access to the school server.  
 
TTSM to Student Manager:  

 
1. Make a MUSAC folder on your laptop eg. C:\MUSAC  

2. Copy the TTSM folder from your server to your laptop 
3. Make a \CM folder on your laptop. Copy CM.MDB, SM.MDB and STAFF.MDB from 

\CM on your server into this folder.  

 
This will allow you to run all the features in TTSM but not Student Manager on your 

laptop. That should be all you need.  
 
System Files:  

To run TTSM you MUST have the MUSAC System 32 files on your laptop. These can be 
loaded from any recent MUSAC CD or from the MUSAC web site.  
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Restoring Data to the server  
This process must be done carefully. MUSAC cannot accept responsibility for any 

problems that may eventuate from users restoring data incorrectly.  
 

The Timetable  
The timetable data is generally stored in the \TTSM\TT folder.  
 

The most important thing is to remember your timetable number. If it is a number 
from 1 to 9 then the files you are looking for are files ending in .5A<timetable 

number> eg. timetable 7 files end in .5A7. Timetables numbered from 10 to 99 end in 
.5<timetable number> eg. timetable 71 end in .571 These files are generally quite 
small and can easily fit on a pen drive.  

 
The files for timetable 71 (for example) are:  

ACTOPTS.571 the option structure  
CLASSES.571 the core class names  
ROOMS.571 the rooms  

STATS.571 the number of days and periods  
TEACHERS.571 the main timetable file  

TEACHOLD.571 an automatic backup - this file is not essential.  
 

A Manual Copy of the Timetable  
Copy the files indicated to a pen drive and then transfer them to the equivalent folder 
on your server.  

 
Option Lines  

1. On your laptop Enter Timetable Assistant  
2. Make sure you load your correct option lines  
3. Go into the Option Editor on your laptop and choose SAVE – Save as a TAS 

OPTION FILE. Choose a sensible name eg. FINAL LINES 2012. Record the path 
where you saved these to or save to a pen drive. The file will be saved as 

FINAL LINES 2012.OPT into whatever path you chose.  
4. The Default TAS Option Line paths for Student Manager are always stored in 

the \TTSM\TAS\OPT folder  

5. Copy this file into the equivalent path on your server  
6. This file can then be loaded on your server when you choose to LOAD OPTION 

LINES in TAS (as long as you choose the correct path ).  
7. You can then enter the Option Editor on your server and save these directly to 

Student Manager as your default lines.  

  
Student Information  

If your student subjects data was originally copied from your server AND the subjects 
on your laptop are still the same ie. a student still has History, Geography, French etc 
(even though they may now be now sorted into classes on your laptop) then you 

may decide NOT to restore these. Many timetablers take the safe option of merely 
restoring the option lines from their laptop and reallocating the students when back at 

school. They can then manually match up the laptop with the server. The TAS 
Import/Export process is a simple and effective process, detailed below.  
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In the Student Editor in TAS there is the ability to export student subject.  
 

Export  
Go into the Student Editor > click Utilities > Export Data. Here choose to export all 

the student's subject data to a pen drive (or some other location).  
 
Import  

On your server go into TAS, loading the appropriate subject set > enter the Student 
Editor > click Utilities > Import Data. You will need to decide how you wish to cope 

with students who already have data. Normally you would choose 'Overwrite' all TAS 
subjects, but if you are nervous about this there is a choice to only overwrite if the 
student has no data on the server or the subjects match (even though the actual 

classes ie. teachers may vary).  
 

Restoring Other Stuff  
Timetable Assistant (TAS) (Useful but not essential)  
The TAS folder is always \TTSM\TAS  

The files in Timetable Assistant are effectively planning files - ie. a 'means to an end' to 
create your timetable. Once the timetable is completed they are not required again. 

They are however useful when it comes to build the timetable for the following year. 
With this in mind you can simply copy the whole TAS folder between machines quite 

happily updating with the newest files. To save time however you may simply copy the 
most recent files in \SIF sub folder (the masks) and \OPT sub folder (practice option 
lines) and the teacher file SCHOOL.TCH.  

 
QuickFind (This is rarely required)  

The only QuickFind files you may wish to copy are the customised timetable entries. 
This would ONLY be required if you have gone to the trouble of also doing all the 
customising for your new timetable at home. Most schools do this on site. Copy 

TT.MDB in the \TTSM folder.  
 

Notes (Generally not necessary)  
These are not essential and can be in several places depending on the type of note you 
may have made. Check the \TTSM\TT\NOTES folder  

 
In Summary  

Please be careful transferring data back to your server. It can be done quite safely but 
(as always) please make sure your backup systems are secure. If you are in any doubt 
please contact your MUSAC agent before proceeding.  

 
Why are the pages I need in QuickFind greyed out?  

The pages have been turned off by a level 3 user, changing the pages a User can see 
by entering the User area > Edit > clicking the green Show Pages button.  
 

How to find which student has a particular enrolment number  
QuickFind > Student Information > type ‘F’ or click Find > click the Enrol# heading 

to sort by this column > scroll to the number you require. Page 8  
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How to show form class sizes  
QuickFind > List Menu > Statistics > choose the Form tab. This area provides a 

powerful process for ensuring your data is accurate particularly when doing MoE 
returns. You can use the right mouse button to check the various rolls from any cells in 

the grid.  
 
How to keep track of students who need extra attention?  

QuickFind > List Menu > Student Lists > Tag the relevant students with the INS key 
> File > Save Selection > Save just those records tagged > enter a file name eg. 

Trouble and an optional description eg. ‘John’s little horrors’ > OK. To later recall this 
list, go back into lists and choose File > Load Selection.  
 

Sending lists to Excel?  
Select the students you want > choose Print > this student list > select the fields to 

print > Next > click Send to file > comma delimited. Make a note of your filename.  
Go to Excel > file open > change "files of type" to all files, so that you can see the file, 
and choose delimited by commas when asked. 

 
 

 
 

 
 
 

 
 

 
 
 

 
 

 
 
 

 
 

 
 
 

 
 

 
 
 

Solutions and Services  
(South Island)  

Ph (03) 338 8800  
solserv@xtra.co.nz  

MUSAC Software Support 
(Nation wide) 

Ph 0800 600 159 
Fax 0800 500 159 

support@massey.ac.nz 

Edtech Ltd  
(North Island)  

Ph (09) 913 9393  
musac@edtech.co.nz  

 


